Перейти к содержимому


- - - - -

Падает интернет при включении IPTV

netgear iptv

  • Авторизуйтесь для ответа в теме
Сообщений в теме: 21

#1 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 31.08.2014 - 19:40

Доброе время суток.

Пользуюсь Netgear R7000 на Qwerty, недавно получил IPTV приставку и замучился с ней. Пробовал родную прошивку, Tomato,  - все равно , как только начинаешь смотреть ТВ, интернет пропадает до отключения приставки. Уже начинаю думать о покупке дешевого рутера, гарантированно работающего с Кверти, который поставить перед R7000. Надо только , чтобы он этот мультикаст только на 1 порт  форвардил.

Или есть другие пути?

#2 ramax

ramax
  • Я подписываюсь. А кто все эти люди?

  • Модератор
  • 8 445 сообщений
  • Пол:Мужчина
  • Город:Новогиреево

Отправлено 31.08.2014 - 19:46

Дело не в мультикасте. Дело в том, чтобы один порт был не маршрутизируемым, а коммутируемым. Проблема обычно в другом.
Сейчас этот роутер включен?

#3 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 01.09.2014 - 15:43

Просмотр сообщенияramax (31.08.2014 - 19:46) писал:

Сейчас этот роутер включен?

Да, включен. Прошивка пока Tomato . Тут люди даже спец маршруты через скрипты прописывают для IPTV : http://tomatousb.ru/...ic.php?p=63#p48 , вот только не знаю, как это для кверти правильно сделать.

#4 Эндрю

Эндрю
  • Легенда форума

  • Root
  • 25 813 сообщений
  • Пол:Мужчина
  • Город:Вешняки

Отправлено 01.09.2014 - 15:45

Вы номер договора напишите свой.

#5 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 01.09.2014 - 16:05

291528-040/14. Он на жену, если что :)

Поставил старый Netgear WNR3500 - тут интернет при просмотре ТВ не падает совсем, но значительно замедляется, включая локалку.

#6 Эндрю

Эндрю
  • Легенда форума

  • Root
  • 25 813 сообщений
  • Пол:Мужчина
  • Город:Вешняки

Отправлено 01.09.2014 - 16:08

Не, вы старый верните, посмотреть что на порту.
Всмысле, с которым проблемы)

#7 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 01.09.2014 - 16:29

ОК, вернул, симптомы те же. Приставка нужна включенной?

#8 Эндрю

Эндрю
  • Легенда форума

  • Root
  • 25 813 сообщений
  • Пол:Мужчина
  • Город:Вешняки

Отправлено 01.09.2014 - 16:59

Пока нет, пк и роутер оставьте

#9 ramax

ramax
  • Я подписываюсь. А кто все эти люди?

  • Модератор
  • 8 445 сообщений
  • Пол:Мужчина
  • Город:Новогиреево

Отправлено 01.09.2014 - 17:19

Просмотр сообщенияaurebus (01.09.2014 - 15:43) писал:

Тут люди даже спец маршруты через скрипты прописывают для IPTV : http://tomatousb.ru/...ic.php?p=63#p48 , вот только не знаю, как это для кверти правильно сделать.
Не надо так делать.
Вот примерно вот так надо делать: http://forum.netgear...pic.php?id=1917
Но не все роутеры имеют такую архитектуру.

А вообще, вот тут http://habrahabr.ru/post/195058/ пишут, что не все нетгиры одинаково полезны в разных регионах.

#10 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 01.09.2014 - 18:06

Просмотр сообщенияramax (01.09.2014 - 17:19) писал:

Просмотр сообщенияaurebus (01.09.2014 - 15:43) писал:

Тут люди даже спец маршруты через скрипты прописывают для IPTV : http://tomatousb.ru/...ic.php?p=63#p48 , вот только не знаю, как это для кверти правильно сделать.
Вот примерно вот так надо делать: http://forum.netgear...pic.php?id=1917
Но не все роутеры имеют такую архитектуру.


Я именно так и сделал, только порты взял из вывода nvram show.
По-другому приставка через Томато -рутер не работает.

Когда приставка только включена и показывает превьюшки каналов, все нормально.
Стоит включить любой канал - пинг даже внутри локалки работает с перебоями, и в сеть не выйти (по wifi).

#11 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 01.09.2014 - 18:31

Просмотр сообщенияramax (01.09.2014 - 17:19) писал:


А вообще, вот тут http://habrahabr.ru/post/195058/ пишут, что не все нетгиры одинаково полезны в разных регионах.

Да, первым делом сделал, чтобы получить русский язык, и доступ к настройкам IPTV в официальной прошивке.

#12 Эндрю

Эндрю
  • Легенда форума

  • Root
  • 25 813 сообщений
  • Пол:Мужчина
  • Город:Вешняки

Отправлено 01.09.2014 - 19:14

Так. У вас на порту сейчас 2 мака
00:02:02:52:D1:A6 и E4:F4:C6:05:90:45
Один из них приставка. Этим 2-м устройствам выдан IP, третье устройство будет бороться за свой IP и отрубит телевидение.
Следовательно, надо понять, ваш ПК шлет свой мак или нет. Отключите ТВ от роутера, подключите свой комп.

#13 ramax

ramax
  • Я подписываюсь. А кто все эти люди?

  • Модератор
  • 8 445 сообщений
  • Пол:Мужчина
  • Город:Новогиреево

Отправлено 01.09.2014 - 20:06

Просмотр сообщенияaurebus (01.09.2014 - 18:06) писал:

Я именно так и сделал, только порты взял из вывода nvram show.
Хотелось бы увидеть текущие значения.
И ещё: вот этот параметр должен быть Enable: Optimize Multicast Traffic

кстати, а вообще интересно: если отключить на этом роутере WiFi вообще, проблема будет наблюдаться?

#14 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 01.09.2014 - 20:53

Просмотр сообщенияЭндрю (01.09.2014 - 19:14) писал:

Так. У вас на порту сейчас 2 мака
00:02:02:52:D1:A6 и E4:F4:C6:05:90:45
Один из них приставка. Этим 2-м устройствам выдан IP, третье устройство будет бороться за свой IP и отрубит телевидение.
Следовательно, надо понять, ваш ПК шлет свой мак или нет. Отключите ТВ от роутера, подключите свой комп.

У меня к сетевым интерфейсам рутера помимо ТВ приставки подключены сетевой накопитель и медиаплеер. Айпи они получают из DHCP пула 192.168.х.х, не думаю, что они борются с приставкой. Компы подключаются по вафле .

E4:F4:C6:05:90:45 это WAN интерфейс рутера

Просмотр сообщенияramax (01.09.2014 - 20:06) писал:

Просмотр сообщенияaurebus (01.09.2014 - 18:06) писал:

Я именно так и сделал, только порты взял из вывода nvram show.
Хотелось бы увидеть текущие значения.
И ещё: вот этот параметр должен быть Enable: Optimize Multicast Traffic

кстати, а вообще интересно: если отключить на этом роутере WiFi вообще, проблема будет наблюдаться?

vlan2ports=0 4 5
vlan1ports=1 2 3 5*
Я пробовал до того играться с Efficient Multicast Forwarding , разницы не было. Попробую еще раз, заодно переключу комп напрямую.

#15 Эндрю

Эндрю
  • Легенда форума

  • Root
  • 25 813 сообщений
  • Пол:Мужчина
  • Город:Вешняки

Отправлено 02.09.2014 - 06:40

Да, попробуйте вайфай отключить, у меня как-то тоже роутер переклинило, либо вайфай работал, либо телевидение.

#16 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 02.09.2014 - 10:44

Опыты с вайфаем не удались, что-то он внезапно плохо безо всякой приставки начал работать во внутренней сети.
Обнулил нврам, перезалил последнюю доступную заводскую прошивку, снова сбросил настройки на заводские и перенастроил с нуля .

С заводской прошивкой - как только настроишь проброс порта на ТВ, пропадает интернет, в настройках интернет порта всё становится по нулям - то есть, "дерутся" за DHCP именно рутер и приставка, что странно, т.к. сети у них вроде разные и приставка получает 10.*, а у рутера был 79.*

#17 ramax

ramax
  • Я подписываюсь. А кто все эти люди?

  • Модератор
  • 8 445 сообщений
  • Пол:Мужчина
  • Город:Новогиреево

Отправлено 02.09.2014 - 12:34

Дерутся они не за ip-адреса, а за MAC'и. Впрочем, этого ни разу на твоём порте не увидели.
Соответственно, исходя из твоего описания, что пока на приставке нет видео-потока, всё нормально, а как только видеопоток включен - интернет пропадает, а сам роутер тормозит, диагноз выглядит так:
чип коммутатора, который внутри роутера, не знает, что такое IGMP-snooping и шлёт весь поток на процессор. Процессор охреневает, и больше ничего делать не может. Скорее всего, это программная ошибка, что прошивка неправильно программирует чип. Но могут быть и ограничения чипа. Тут я дятел, точно сказать не могу.

Исходя из этого, а также моего давнишнего неприятия оборудования Netgear, рекомендую его выкинуть и поставить что-нить работающее. Например, Асус RT-N66, как у меня.

#18 Erdees

Erdees
  • Белый и пушистый

  • Администратор
  • 4 315 сообщений
  • Пол:Мужчина
  • Город:/dev/urandom

Отправлено 03.09.2014 - 09:02

От себя еще добавлю - лично мной протестированы Zyxel Keenetic (от малого до Ultra II), Asus RT-N16, RT-N66, Buffalo WZR-1750DHP вместе с dd-wrt (использую сейчас).
Все они ведут себя отлично с ТВ приставками и раздачей Интернет.

#19 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 03.09.2014 - 10:06

Я не пробовал только dd-wrt на R7000.

C Tomato: канал полностью  не отваливается, но по симптомам - multicast storm, т.е. и интернет и локалка еле дышат при использовании приставки.
С официальной прошивкой: отваливается интернет порт. Локалка и ТВ работают как должны .

Пока что включил R7000 после WNR3500L, который тянет ТВ . Так всё работает , посмотрим, может со временем допилят прошивку под R7000.

Спасибо за советы / диагностику.

Сообщение отредактировал aurebus: 03.09.2014 - 10:08


#20 mimimi

mimimi
  • Договор № 18822-061/05

  • Динозавр Форума
  • 2 043 сообщений
  • Пол:Мужчина
  • Город:Сев. Бутово

Отправлено 04.09.2014 - 19:24

Просмотр сообщенияaurebus (02.09.2014 - 10:44) писал:



С заводской прошивкой - как только настроишь проброс порта на ТВ, пропадает интернет, в настройках интернет порта всё становится по нулям - то есть, "дерутся" за DHCP именно рутер и приставка, что странно, т.к. сети у них вроде разные и приставка получает 10.*, а у рутера был 79.*
Я конечно не профи, но. Соответствуют ли номера портов обозначениям на роутере? Было просто такое.

#21 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 08.09.2014 - 13:57

Просмотр сообщенияmimimi (04.09.2014 - 19:24) писал:

Просмотр сообщенияaurebus (02.09.2014 - 10:44) писал:

С заводской прошивкой - как только настроишь проброс порта на ТВ, пропадает интернет, в настройках интернет порта всё становится по нулям - то есть, "дерутся" за DHCP именно рутер и приставка, что странно, т.к. сети у них вроде разные и приставка получает 10.*, а у рутера был 79.*
Я конечно не профи, но. Соответствуют ли номера портов обозначениям на роутере? Было просто такое.

Иногда в альтернативных прошивках нумерация наоборот, да. Но тут другое. Если б не соответствовали - ТВ приставка не завелась бы .

#22 aurebus

aurebus
  • Новичок

  • Пользователь
  • 11 сообщений
  • Пол:Мужчина

Отправлено 27.05.2015 - 22:13

Просмотр сообщенияaurebus (31.08.2014 - 19:40) писал:


Пользуюсь Netgear R7000 на Qwerty, недавно получил IPTV приставку и замучился с ней. Пробовал родную прошивку, Tomato,  - все равно


Поскольку яндекс отправляет сюда при поиске решения, отвечу сам себе - нужна вот эта прошивка от нашего умельца . Нашёл через ixbt, где он также обитает.





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 скрытых пользователей